Вы отправили работу на проверку эксперту. Укажите номер телефона на него придет СМС
Скачать .pdf

Циклический алгоритм обработки массива чисел, записанный на алгоритмическом языке

Ответами к заданиям являются слово, словосочетание, число или последовательность слов, чисел. Запишите ответ без пробелов, запятых и других дополнительных символов.

1
1

В таблице Dat хранятся положительные или отрицательные целые числа. Определите, что будет напечатано в результате выполнения следующего алгоритма, написанного на трех алгоритмических языках.

Алгоритмический язык

алгнач    целтаб Dat[1:10]    цел к, т, пит    Dat[1]:= 7; Dat[2]:= -8    Dat[3]:= 3; Dat[4]:= б    Dat[5]:= -4; Dat[6]:= 3    Dat[ 7 ] : = 5; Dat[8]:= -5    Dat [9] := 7; Dat [10] := 1    num := 1; m := Dat[1]        нц для k от 2 до 10        если Dat[k] * m < 0 то            m := Dat[k]; num := k        все    кц    вывод numкон

Бейсик

DIM Dat (10)AS INTEGER    Dat (1) - 7:	Dat (2) = -8    Dat (3) =3:	Dat (4) = 6    Dat (5) = -4	Dat (6) =3    Dat (7) = 5:	Dat (8) = -5    Dat (9) = 7:	Dat(10) = I    num = 1: m = Dat (1)        FOR k = 2 TO 10            IF Dat(k) * m < 0 THEN                m = Dat(k)	                num = k            END IF	        NEXT k	PRINT num	END	

Паскаль

var k, m, num: integer;Dat: array[1..10] of integer;begin    Dat[1]:= 7; Dat[2]:= -8;    Dat[3]:= 3; Dat[4]:= 6;    Dat[5]:= -4; Dat[6]:= 3;    Dat[7]:= 5; Dat[8]:= -5;    Dat [9] := 7; Dat[10] := 1;    num:= 1; m:= Dat[l];        for k:= 2 to 10 do begin            if Dat[k] * m < 0 then            begin                m := Dat [k]; num := k            end        end;        write(num);end.
2
2

В таблице Dat хранятся данные о количестве проданных единиц товаров 10 типов (Dat[1] — проданных товаров первого типа, Dat[2] — второго типа и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алгнач целтаб Dat[1:10] цел k, m, day Dat [1] := 7; Dat [2] := 1 Dat [3] := 3; Dat [4] := 3 Dat [5] := 2; Dat [6] := 2 Dat [7] := 5; Dat [8] := 5 Dat[9] := 7; Dat [10] := 1  day := 1; m := Dat[1]  нц для к от 2 до 10  если Dat[к] < m то   m := Dat[к]; day := к  все КЦ вывод dayкон

Бейсик

DIM Dat (10) AS INTEGER Dat (1) = 7: Dat (2) = 1 Dat (3) = 3: Dat (4) = 3 Dat (5) = 2: Dat (6) = 2 Dat (7) = 5: Dat (8) = 5 Dat (9) = 7: Dat (10) = 1 day = 1: m = Dat(1)  FOR k = 2 TO 10   IF Dat(k) < m THEN    day = k    m - Dat(k)   END IF  NEXT kPRINT dayEND

Паскаль

var k, m, day: integer;Dat: array[1..10] of integer;begin Dat [1] := 7; Dat [2] := 1; Dat [3] := 3; Dat [4] := 3; Dat [5] := 2; Dat [6] := 2; Dat [7] := 5; Dat [8] := 5; Dat [9] := 7; Dat [10] := 1; day:= 1; m:= Dat[l]; for k:= 2 to 10 do begin  if Dat[k] < m then  begin   m := Dat [k];   day := k  end end; write(day); end.
3
3

В таблице Dat хранятся положительные или отрицательные целые числа. Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх алгоритмических языках.

Алгоритмический язык

алг<br />нач<br />    целтаб Dat[1:10]<br />    цел k, m, num<br />    Dat[1] := -7; Dat[2] := -8<br />    Dat[3] := 3; Dat[4] := 6<br />    Dat[5] := -4; Dat[6] := 3<br />    Dat[7] := 5; Dat[8] := 5<br />    Dat[9] := 7; Dat[10] := 1<br />        num := 1; m := Dat[1]<br />        нц для к от 2 до 10<br />        если Dat[к]* m < 0 то<br />            m := Dat[к]; num := к<br />        все<br />    кц<br />    вывод m<br />кон

Бейсик

DIM Dat(10) AS INTEGER<br />    Dat (1) = -7: Dat(2) = -8<br />    Dat (3) = 3: Dat(4) = 6<br />    Dat (5) = -4: Dat(6) = 3<br />    Dat (7) = 5: Dat(8) = 5<br />    Dat(9) = 7: Dat(10) = 1<br />    num = 1: m = Dat(1)<br />        FOR k = 2 TO 10<br />            IF Dat(k)* m < 0 THEN<br />                m = Dat(k)<br />                num - k<br />            END IF<br />        NEXT k<br />PRINT m<br />END

Паскаль

var k, m, num: integer;<br />Dat: array[ 1.. 10 ] of integer;<br />begin<br />    Dat[1] := -7; Dat[2] := -8;<br />    Dat [ 3 ] : = 3; Dat[4] : = 6;<br />    Dat [5] := -4; Dat[6] := 3;<br />    Dat[7] := 5; Dat[8] := 5;<br />    Dat [9] := 7; Dat[10] := 1;<br />    num:= 1; m:= Dat[1];<br />    for k:= 2 to 10 do begin<br />        if Dat[k]* m < 0 then<br />        begin<br />            m := Dat [k]; num := k<br />        end<br />    end;<br />    write (m);<br />end.
4
4

В таблице Dat хранятся данные о количестве проданных единиц товаров 10 типов (Dat[1] — проданных товаров первого типа, Dat[2] — второго типа и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг		нач		 целтаб Dat[1	: 10]	 цел k, m		 Dat [1] := 45;	Dat [2] : = 55 Dat [3] := 40; Dat [4] : = 15 Dat [5] := 20; Dat [6] : = 80 Dat [7] := 35; Dat [ 8] : = 70 Dat [9] := 10; Dat [10] := 45 m:= Dat[1]		  нц для к от 4 до 10	  если Dat[к] <= Dat[1] TO   m:= m + Dat [к]	  все		 кц вывод mкон

Бейсик

DIM Dat(10) AS INTEGER Dat(1)= 45: Dat(2)= 55 Dat(3)= 40: Dat(4)= 15 Dat(5)= 20: Dat(6)= 80 Dat(7)= 35: Dat(8)= 70 Dat(9)= 10: Dat(10)= 45 m = Dat(1)  FOR k = 4 TO 10  IF Dat(k) <= Dat(1)  THEN   m = m + Dat (k)  END IF NEXT kPRINT mEND

Паскаль

var k, m: integer;Dat: array[1..10] of integer;begin Dat[1]:= 45; Dat[2]:= 55; Dat[3]:= 40; Dat[4]:= 15; Dat[5]:= 20; Dat[6]:= 80; Dat[7]:= 35; Dat[8]:= 70; Dat[9]:= 10; Dat[10]: = 45; m:= Dat [1]; for k:= 4 to 10 do begin  if Dat[k] <= Dat[l] then  begin   m:= m + Dat [k]  end end;write (m);end.
5
5

В таблице Dat хранятся данные о количестве проданных единиц товаров 10 типов (Dat[1] — проданных товаров первого типа, Dat[2] — второго типа и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг		нач		 целтаб Dat[1:10]	 цел k, m		 Dat[1] := 45; Dat[2] : = 55 Dat[3] := 40; Dat[4] : = 15 Dat[5] := 20; Dat[6] := 80 Dat[7] := 35; Dat[8] : = 70 Dat[9] := 10; Dat[10] := 45 m:= Dat[1]  нц для к от 4 до 10  если Dat[к] >= Dat[1] то   m:= m + Dat [к]	  все		 кц		 вывод m		кон

Бейсик

DIM Dat(10) AS INTEGER Dat(1)= 45: Dat(2)= 55 Dat(3)= 40: Dat(4)= 15 Dat(5)= 20: Dat(6)= 80 Dat(7)= 35: Dat(8)= 70 Dat(9)= 10: Dat(10)= 45 m = Dat (1)  FOR k = 4 TO 10   IF Dat(k) >= Dat (1)   THEN    m = m + Dat (k)   END IF NEXT kPRINT mEND

Паскаль

var k, m: integer;Dat: array[1..10] of integer;begin Dat[1] := 45; Dat[2] := 55; Dat[3] := 40; Dat[4] := 15; Dat[5] := 20;. Dat[6] := 80; Dat[7] := 35; Dat[8] := 70; Dat[9] := 10; Dat[10] := 45; m:= Dat[1]; for k:= 4 to 10 do begin  if Dat[k] >= Dat[1] then  begin   m:= m + Dat[k]  end end; write(m);end.
6
6

В таблице Dat хранятся данные о количестве проданных единиц товаров 10 типов (Dat[1] — проданных товаров первого типа, Dat[2] — второго типа и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алгнач целтаб Dat[1:12] цел k, m, month Dat[1]:= 2; Dat[2]:= 8 Dat[3]:= 6; Dat[4]:= 3 Dat[5]:= 8; Dat[6]:= 2 Dat[7] := 3; Dat[8] := 7 Dat[9]:= 4; Dat[10]:= 4 Dat[11] := 8; Dat[12] := 7 month := 1; m := Dat[1]  нц для к от 2 до 6   если Dat[к] > m то    m := Dat[к]    month := к   все  кцвывод monthкон

Бейсик

DIM Dat(12) AS INTEGERDat(1)= 2: Dat(2)= 8Dat(3)= 6: Dat(4)= 3Dat(5)= 8: Dat(6)= 2Dat(7)= 3: Dat(8)= 7Dat(9)- 4: Dat(10)= 4Dat(11)= 8: Dat(12)= 7month = 1: m = Dat(1)FOR k = 2 TO 6  IF Dat(k) > m THEN    m = Dat(k)    month = k  END IFNEXT kPRINT monthEND

Паскаль

var k, m, month: integer;Dat: array[1.,12] of integer;begin Dat[1] := 2; Dat[2] := 8; Dat[3] := 6; Dat[4] := 3; Dat[5] : = 8; Dat[6] := 2; Dat[7] : = 3; Dat[8] := 7; Dat[9] := 4; Dat[10] := 4; Dat[11] := 8; Dat [12] := 7; month := 1; m := Dat[1]; for k := 2 to 6 do begin  if Dat[k] > m then  begin   m := Dat [k];   month := k  end end; write(month);end.
7
7

В таблице Dat хранятся данные о количестве проданных единиц товаров 10 типов (Dat[1] — проданных товаров первого типа, Dat[2] — второго типа и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алгнач целтаб Dat[1:12] цел k, m, month Dat[1]:= 2; Dat[2]:= 8 Dat[3]:= 6; Dat[4]:= 3 Dat[5]:= 8; Dat[6]: = 2 Dat[7] := 3; Dat[8] := 7 Dat[9]:= 8; Dat[10]: = 3 Dat[11]:= 8; Dat[12]: = 7 month := 7; m := Dat[7]  нц для к от 8 до 12   если Dat[к] > m то    m := Dat[к];    month := к  все кц вывод monthкон

Бейсик

DIM Dat(12) AS INTEGERDat(1)= 2: Dat(2)= 8Dat(3)= 6: Dat(4) = 3Dat(5)= 8: Dat(6)- 2Dat(7)= 3: Dat(8)= 7Dat(9)= 8: Dat(10)= 3Dat(11)= 8: Dat(12)= 7month = 7: m = Dat(7)FOR k = 8 TO 12  IF Dat(k) > m THEN    m = Dat(k)    month = k  END IFNEXT kPRINT monthEND

Паскаль

var k, m, month: integer;Dat: array[1..12] of integer;begin Dat[1] := 2; Dat[2] := 8; Dat[3] := 6; Dat[4] := 3; Dat[5] := 8; Dat[6] := 2; Dat[7] := 3; Dat[8] := 7; Dat[9] := 8; Dat[10] := 3; Dat[11] := 8; Dat[12] := 7; month := 7; m := Dat[7]; for k := 8 to 12 do begin  if Dat[k] > m then begin   m := Dat [k];   month := k  end end;write(month);end.
8
8

В таблице Dat хранятся данные о количестве проданных единиц товаров 10 типов (Dat[1] — проданных товаров первого типа, Dat[2] — второго типа и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алгнач целтаб Dat[1:10] цел k, m, day Dat [1] := 7; Dat [2] := 2 Dat [3] := 3; Dat [4] := 3 Dat [5] := 4; Dat [6] := 4 Dat [7] := 5; Dat [8] := 5 Dat [9] := 7; Dat [10]:= 6 day := 1; m := Dat [1]  нц для k от 2 до 10  если Dat[к] >= m то   m := Dat[к]; day := к  все кц вывод dayкон

Бейсик

DIM Dat(10) AS INTEGER Dat (1) = 7: Dat (2) =2 Dat (3) = 3: Dat (4) = 3 Dat (5) = 4: Dat (6) = 4 Dat (7) = 5: Dat (8) = 5 Dat (9) = 7: Dat (10) = 6 day = 1: m = Dat(1)  FOR k = 2 TO 10   IF Dat (k) >= m THEN    m = Dat (k)    day = k   END IF  NEXT kPRINT dayEND

Паскаль

var k, m, day: integer;Dat: array[1..10] of integer;begin Dat[1] := 7; Dat[2] := 2; Dat[3] := 3; Dat[4] := 3; Dat[5] := 4; Dat[6] := 4; Dat[7] := 5; Dat[8] := 5; Dat[9] := 7; Dat[10] := 6; day:= 1; m:= Dat[1]; for k:= 2 to 10 do begin  if Dat[k] >= m then  begin   m := Dat [k];   day := k  end end; write(day);end.
9
9

В таблице Dat хранятся данные о количестве проданных единиц товаров 10 типов (Dat[1] — проданных товаров первого типа, Dat[2] — второго типа и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг	нач	 целтаб Dat [1:10] цел к, m Dat [1] = 45; Dat[2]:= 55 Dat [3] = 40; Dat[4]:= 15 Dat [5] = 20; Dat[6]:= 80 Dat [7] = 35; Dat[8]:= 70 Dat [9] = 10 Dat [10] := 45 m:= Dat[l]	  нц для к от 2 до 10	  если Dat[к] < Dat[l] то	   m := m + Dat[k]  все	 кц вывод m	кон

Бейсик

DIM Dat(10) AS INTEGER Dat(1)= 45 Dat(2)= 55 Dat(3)= 40 Dat(4)= 15 Dat(5)= 20 Dat(6)= 80 Dat(7)= 35 Dat(8)= 70 Dat(9)= 10 Dat(10)= 45 m = Dat(1)	  FOR k = 2 TO 10   IF Dat(k) < Dat (1)	    THEN	     m = m + Dat(k)   END IF	  NEXT k	PRINT m	END	

Паскаль

var k, m: integer;Dat: array[1..10] of integer;begin Dat[1]:= 45; Dat[2]:= 55; Dat[3]:= 40; Dat[4]:= 15; Dat[5]:= 20; Dat[6]:= 80; Dat[7]:= 35; Dat[8]:= 70; Dat[9]:= 10; Dat[10]:= 45; m:= Dat [1]; for k:= 2 to 10 do begin  if Dat[k] < Dat[1] then  begin   m:= m + Dat [k]  end end; write(m);end.
10
10

В таблице Dat хранятся данные о количестве проданных единиц товаров 10 типов (Dat[1] — проданных товаров первого типа, Dat[2] — второго типа и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг		нач		 целтаб Dat[1	: 10]	 цел k, m		 Dat [1] := 45; Dat [2] : = 55 Dat [3] := 40; Dat [4] : = 15 Dat [5] := 20; Dat [6] : = 80 Dat [7] := 35; Dat [8] : = 70 Dat [9]:= 10; Dat [10] := 45 m:= Dat[1]  нц для к от 4 до 10	  если Dat[к] > Dat[1] TO   m:= m + Dat [к]	  все		 кц	 вывод mкон

Бейсик

DIM Dat(10) AS INTEGER Dat(1) = 45 Dat(2) = 55 Dat(3) = 40 Dat(4) = 15 Dat(5) = 20 Dat(6) = 80 Dat(7) = 35 Dat(8) = 70 Dat(9) = 10 Dat(10) = 45 m = Dat (1)	 FOR k = 4 TO 10	  IF Dat(k) > Dat (1)	  THEN		   m = m + Dat(k)  END	IF	 NEXT k		PRINT m		END	

Паскаль

var k, m: integer;	Dat: array[1..10]	 of integer;	begin	 Dat[1]:= 45; Dat[2]:= 55; Dat[3]:= 40; Dat[4]:= 15; Dat[5]:= 20; Dat[6]:= 80; Dat[7]:= 35; Dat[8]:= 70; Dat[9]:= 10; Dat[10]:= 45; m:= Dat[1];	 for k:= 4 to 10 do begin	  if Dat[k] > Dat[l] then	  begin	   m: = m + Dat [k]	  end	 end;	write(m); end.
0 из 0
Ваш ответ Правильный ответ Первичный балл

Здесь появится результат тестовой части.

Нажмите на кнопку «Завершить работу», чтобы увидеть правильные ответы.

503 110
Уже готовятся к ЕГЭ и ОГЭ.
Присоединяйся!
Мы ничего не публикуем от вашего имени
или
Ответьте на пару вопросов
Вы...
Ученик Учитель Родитель